WMS layer not working?

completed
#1

Is WMS not working in the Polish language version?
Are there any WMS restrictions related to the amount of data?
I tested WMS layer with recommended for Poland …

#2

Hi,
could I ask you what service do you use? I think that link is probably obsolete or maybe is there another issue with the service (language can not influence it)
Thanks, Petr

#4

I’m mostly using WMS for aerial pics. Most services are working fine, some don’t. E.g. https://www.geodatenportal.sachsen-anhalt.de/gateway/gateto/LVermGeo_intern-DOP100_OpenData? is working fine in QGIS, but does not load in LocusGIS. No idea why…

#5

Hi,
I tried the URL https://www.geodatenportal.sachsen-anhalt.de/gateway/gateto/LVermGeo_intern-DOP100_OpenData in QGIS and I can’t connect. Is the URL correct, please?
Thanks,
Petr

#8

Shit, after update to ver. 0.12.8 no WMS-layer is working anymore!!! I’m just out in the field and can’t work today…

#9

Good day Osmoderma,
this is little unfortunately. I get report on “similar” problem in Locus Map few days ago.
In that case helped to clear cache of WMS maps. Give it a try and remove LocusGIS/cache/maps directory on your device.

#10

Just did so, cache is empty now. Unfortunately the former WMS layer cannot be imported again (‘Process unsuccessful’). Had some tries with an saved WMS address as well as an newly imported address…

And all WMS layers are lost now in all projects (layer is reset to ‘Classic’ in all projects (which had different WMS layers depending on several federal states)

#11

At least I did a full reset of LocusGIS. All saved WMS addresses are lost now (ok, this was foreseeable) but I cannot manually enter a new WMS address…

Importing of recommended WMS addresses (LGIS website) works or not works: e.g. DOP 20 Saxony can be imported but pics are not loaded. E.g. DOP 20 Brandenburg (which as been saved before) cannot be imported (‘Not successful’)

#12

All, once used WMS maps, should be stored in Map manager > WMS tab.
There is maybe small issue that map do not re-initialize automatically after cache is cleared. So open Map manager and in WMS tab, tap on three dot menu for every map you want to use and try to re-initialize it. Then it should work again.

#13

Hmmm, re-initialisation worked but WMS layers will not be loaded in map view (still stay empty…)

#14

After some days out in the field without aerial pics I#m back to office. Today i completely de-installed LGIS from my Tab Active 2 and re-installed then.
Situation is now:

  • suggested WMServices: none of the involved is working anymore (tried some which I was using for years). E.g. I tried German/Saxonia DOP RGB: can be involved to WMS tab but pics are not shown in map.
  • manual input: none of my formerly used WMServices (I regularely used manual input for years) can be added anymore (e.g. Berlin aerial pics 2014: http://fbinter.stadt-b.de/fb/wms/senstadt/kluftbild2014 (was working fine before upadate…)

Please, help anyway!

#15

Hello,

I had the same problem with WMS services from Saxony. For me it helped to reinitialize the WMS service and change the transparency.
Unfortunately this is a bit problematic because the mask is not displayed completely.

#16

Ok, I found solution for Saxonian aerial pics (DOP RGB): something must have changed… Formerly ist was sufficient only to activate the WMS layer to see aerial pics.

Now: involve WMS layer into one project. Then: in layer list of project tap “Settings” of DOP RGB and switch SN DOP 020 RGB on --> now it works!

I really don’t know what has changeed, this step was not necessary in earier times… But for now: I’m back in the field with LocusGIS!

Thanks!

#17

Hi,
thank you for the post. You’re right it’s needed to switch the layers on for the first time to display the WMS. I’ll ask others if we can somehow improve it.
Thanks, Petr

#18

Correct URL for Saxony-Anhalt (working in 0.12.10 when switching layer on in ‘settings’) is: https://www.geodatenportal.sachsen-anhalt.de/wss/service/ST_LVermGeo_DTK_guest/guest?

1 Like